Cloud Provider Database Issue
Incident Report for Trustfull
Resolved
The situation is now resolved and all systems now work as expected.

We apologize for the inconvenience, we encourage you to reach out to us if you report any further issues.
Posted May 26, 2022 - 11:00 CEST
Monitoring
A fix has been deployed and the engineering team is closely following the issue.
Posted May 25, 2022 - 11:00 CEST
Identified
Our engineering team has identified an issue impacting the Fido systems. Between 2022-05-22 00:00 UTC and 2022-05-24 12:00 UTC, some customers may have experienced failures with receiving enriched data.

We have implemented a fix to resolve this issue and are monitoring the situation closely. We will post another update as soon as the issue is fully resolved.
Posted May 24, 2022 - 16:00 CEST
Investigating
Our engineering team is currently investigating an issue impacting our Cloud Control Panel and API. At this time, users may experience increased error rates when interacting with various services (including Fido Phone, Fido Email, Fido Browser, Fido Device and Fido IP) on Dashboard or when making API requests.

We apologize for the inconvenience and will share an update once we have more information.
Posted May 24, 2022 - 15:00 CEST